首页>博客>正文内容

Cocos2d-x v3.16正式版发布啦!

分享

2017-10-09 作者: cocos

Cocos2d-x v3.16版本使用如下Android工具链进行测试:

  • Android Studio 2.3.3
  • NDK r14

特性

  • 更好地支持 creator_to_cocos2dx 这个Cocos Creator的插件
  • 新增 LayerRadiaGradientLayer
  • 支持__Android Studio 2.3.3__
  • 修复lua工程在Xcode 8.0+模拟器崩溃问题
  • 回退CocosStudio的reader和flatbuffer
  • 修复iOS 11编译错误
  • 使用bullet的预编译库以加快编译速度
  • 去除Windows 10 metor模式、Windows Phone和Tizen的支持
  • Web引擎更新Spine runtime到v3.5.35特性介绍

更好地支持 creator_to_cocos2dx

creator_to_cocos2dx是一个Cocos Creator的插件。该插件用于导出Creator创建的场景内容给cocos2d-x的C++/Lua工程使用。

通过使用该插件,可以把Cocos Creator当成cocos2d-x的场景编辑器。该插件目前支持这些特性,会持续支持其他新的特性。有些特性只在v3.16+版本支持,比如RichText img标签。

插件的详细使用方法可以参考插件仓库的the READE,欢迎使用并给与反馈。

%e5%b1%8f%e5%b9%95%e5%bf%ab%e7%85%a7-2017-10-09-%e4%b8%8b%e5%8d%884-08-59

Scene effect in cocos creator

%e5%b1%8f%e5%b9%95%e5%bf%ab%e7%85%a7-2017-10-09-%e4%b8%8b%e5%8d%884-09-41

Scene effect in cocos2d-x

LayerRaidalGradient

LayerRadialGradien和LayerColor类似,它会在制定的圆里绘制颜色,效果如下:

%e5%b1%8f%e5%b9%95%e5%bf%ab%e7%85%a7-2017-10-09-%e4%b8%8b%e5%8d%884-10-33

Lua工程在Xcode 8.0+模拟器崩溃问题

v3.16版本之前,Lua工程在Xcode 8.0+模拟器会崩溃。这是luajit本身的一个bug,v3.16版本修复了这个问题。如果不想更新引擎,也可以直接更新luajit。

修复iOS 11编译错误

v3.16版本之前,CCFileUtils使用system()函数来删除目录。iOS 11删除了system,因此导致了编译错误。改版本修复了这个问题。对应的PR链接在这里,如果不想更新引擎的话,可以参考该PR的改动合并以修复这个问题。

Cocos Studio

v3.15更新了flatbuffer,破坏了Cocos Studio reader的兼容性。该版本回退了flatbuffer和Cocos Studio的reader。

如果不想更新引擎的话,可以手动从改版本或者v3.15之前的版本拷贝flatbuffer和Cocos Studio的reader。

提高编译速度

大部分的项目不需要bullet,因此这个版本使用bullet的预编译库以加快编译速度。后续还会继续使用更多预编译库,比如Box2D,3D粒子系统等以加快编译速度。

该版本同时修复了大量的warning,后续版本也会持续修复warning。

去除支持一些平台

由于人力资源问题,改版本删除了一些平台的支持。

Windows 10的metro模式和Windows Phone平台一直是微软的员工在负责维护了,但是他们决定不再继续维护了,而我们人力资源不足,因此去除支持这两个平台。不过在Windows 10仍然可以使用Win32工程。

同样由于人力资源问题,该版本去除了Tizen平台的支持。

下载地址

参与讨论

登录 后参与讨论

搜索博客