cocos2d-x3.4以前旧版本2d-x用户使用cocos2.1以上版本的方法

2015.3.5 技术干货 by cocos

2.1之后,cocos提供了framework代替2d-x作为开发者的游戏引擎,framework当前可以理解为编译好的2d-x版本,不需要开发者手动编译。

Framework的升级是比较简单,v2.1.2beta开始,在打包时可以选择framework版本,然后cocos就会帮你替换framework的链接,修改为对应版本的framework。Cocos v2.2开始还会提供一个专门的接口来做这件事。

对于2d-x用户,每次升级Cocos都升级2d-x的成本是比较高的。目前我们单独提供了reader的源码,可以通过替换reader的源码来实现读取新版本cocos导出的数据。

具体操作流程:(注意备份,避免操作过程哪一步操作错了,造成难以挽回的错误)

1.下载reader:

reader的下载地址为:

https://git.oschina.net/ZSD/cocos-reader

直接下载ZIP源码。

2.替换代码:

从下载下来的zip里边找到所需版本的cocos文件夹,将里边的两个文件夹替换你项目目录下cocos目录中两个同名文件夹。

3.清理项目、重新编译即可。

目前我们只提供了2d-x3.4beta0和3.4两个版本的reader。

仅测试替换2d-x3.3rc1开始几个版本reader,未测试2d-x3.2之前的版本。

原帖地址:
http://www.cocoachina.com/bbs/read.php?tid-287106.html